Introductory Training Manual
Table of Contents

Introduction

  About This Manual 5

Using LARSA 4D

  Screen Overview 7
  LARSA’s Terminology 7
  Basic Modeling Procedure 8

Creating a 2D Frame

  Units 9
  Materials and Sections 10
  Joints and Members (Drawing) 11
  Joints and Members (Spreadsheets) 14
  Restraints and Properties (the Model Data Explorer) 14
  Load Cases 23
  Running the Analysis 25
  Results 25

Creating a 3D Frame

  Duplicating Joints 31
  Adding New Member 32
  Viewing the Structure from Different Angles 33
  Running the Analysis 34
  Results 34

Tunnel Example and Generation Tools

  Model Setup 37
  Extruding the Tunnel 37
  Extruding with User Coordinate Systems 39

Basic Live Load Analysis

  Model Setup 47
  Vehicle Load Pattern 48
  Lane Definition 49
  Moving Load Case 50
  Moving Load Analysis 51
  Stepping Through Displacements 51
  Stress Envelopes 52
Introduction

About This Manual

This is the introductory training manual for LARSA 4D. In this manual, we will cover:

- Setting Project Units
- Importing Materials and Sections
- Drawing Joints and Members, and Grids
- Input Spreadsheets for Joints and Members
- Restraints and Member Orientation Angle
- Selection, Unselection, and Explorers
- Load Cases and Loads
- Input and Results Spreadsheets (loads, reactions, stresses)
- Graphical Results Diagrams (deformation, member forces)

About LARSA 4D

LARSA 4D is an advanced multipurpose 3D structural analysis package featuring a powerful graphical user interface and an analysis engine with unmatched analytical features including influence line and surface based live load analysis, staged construction analysis, time-dependent material properties and segmental construction analysis, hysteretic and seismic element and seismic analysis, and progressive collapse.

The LARSA structural analysis engine has been in commercial use for over 25 years. During this time LARSA has become the most trusted software of its kind for segmental, cable-stayed, suspension, steel girder and other bridge forms, as well as other structures requiring advanced staged construction analysis, geometric and material nonlinearity, or complex three-dimensional geometry. With short-span pedestrian to major long-span crossing completed in eight countries and hundreds of cities, LARSA is recognized by leading engineers as the premier software for the design and analysis of today’s most iconic structures. We have come a long way since LARSA was first available on VAX super-mini computer decades ago.

LARSA, Inc. has always been an industry leader. LARSA was the first offer an individual PC-based DOS structural analysis package with geometric and material nonlinearity analysis in 1986. In 1994, LARSA took the early next step to Microsoft Windows with a point-and-click graphical user interface and two years later was the first off elastic/perfectly plastic pushover analysis. Today, LARSA's flagship LARSA 4D software products continue to lead the field of bridge software with robust staged construction integrated with nonlinear analysis, influence-surface based live loading, and other complex design needs such as for high-speed rail bridges. Complemented with unique and innovative client support systems, LARSA 4D makes engineers feel comfortable as our developers and support personnel work closely with each client to develop the tools clients need to make their work more efficient and effective.

If you have any questions completing this training manual, you are welcome to contact LARSA’s Support Team at support@lars4d.com.
Welcome to LARSA 4D.

Screen Overview

The LARSA 4D screen looks like the window in the figure below. In addition to the usual components of a Windows application, like the menu bar and tool bar, LARSA 4D has a window bar at the bottom of the screen to switch between open windows — such as graphics windows and spreadsheets — and what we call Explorers on the right side of the screen.

LARSA's Terminology

Here are some of the special terms LARSA 4D uses:
• “Properties” refer to the project input that defines the behavior of the elements in the model, including material properties, cross-sectional properties, nonlinear spring stiffness properties, and time-dependent material properties.
• “Geometry” refers to the joints and elements that make up the structure.
• “Joints” are connection points, or nodes, between elements. Joints have 6 degrees of freedom (DOF), three directions in translation and three in rotation.
• “Members” are 2-node elements, including beams and beam-columns, cables and trusses.
• “Springs” refer to spring elements used as 2-node springs and 1-node foundation springs. A spring can be linear elastic, nonlinear elastic or nonlinear inelastic.

Basic Modeling Procedure

LARSA 4D users normally follow these steps when creating a new model:

• Set project units from Input Data → Units.
• Import material properties from Input Data → Materials.
• Import section properties from Input Data → Sections.
• Create the geometry, either by drawing, using the spreadsheets (Input Data → Geometry), or the Model Data Explorer.
• Create load cases and load combinations, either using the spreadsheets (Input Data → Load Cases & Combinations), or the Load Cases Explorer.
• Running an analysis.
• Inspecting results graphically and numerically (Results → Spreadsheets).

The rest of this manual will illustrate these steps.
Creating a 2D Frame

This tutorial guides you through the creation and analysis of a simple 2D frame. The key concepts we will go over are:

- Setting Project Units
- Importing Materials and Sections
- Drawing Joints and Members, and Grids
- Input Spreadsheets for Joints and Members
- Restraints and Member Orientation Angle
- Selection, Unselection, and Explorers
- Load Cases and Loads
- Input and Results Spreadsheets (loads, reactions, stresses)
- Graphical Results Diagrams (deformation, member forces)

Units

The first step in any LARSA 4D project is to set the units used for the various measures used.

Units in LARSA 4D come in six categories: coordinates, sections, materials, loads, springs/isolators, mass elements. Each category can make use of different units for convenience. Coordinates are often entered in meters or feet, while sections are often specified in inches or centimeters. The Units window is arranged in a grid, with the unit categories arranged vertically and the unit types (length, force, temperature) horizontally.

Open the Input Data → Units menu command.

Setting Project Units
If any units do not match the American units shown in the figure, change them and then click **Apply Conversion**.

These units control input data. Units for results are set separately, and can be selected even after the analysis, using the **Results → Units** command.

## Materials and Sections

The next step is to enter or import material and section properties for the member elements. LARSA 4D comes built-in with the properties of various types of steel, concrete, wood, and other common materials. You must import into your project the materials you want to use.

Open the **Input Data → Materials** command.

### Importing Standard Materials

Click the materials you want to use in the project so that they are checked, and then click **OK**. In this example, we’ll use A992 steel.

You can verify that the materials made it into the project by using the materials spreadsheet (in **Input Data → Properties**).

Next we will import section definitions into the project.

Open **Input Data → Sections**.
Importing Standard Cross-Sections

The built-in section databases include the American AISC tables. As with materials, click the sections you want to use so that they are checked.

- Choose W24x76 and W8x31.

You will lose your choices if you change to a different database or section shape group, so don’t do that.

- Click **Import**.

Sections that have been imported into the project all go into the sections spreadsheet. If the materials spreadsheet is still open, just click the **Sections** tab at the top to see the section.

Section properties can also be input directly into the sections spreadsheet. You may input properties or shape dimensions. When using shape dimensions, you must right-click the section and choose **Calculate Properties from Shape Parameters** any time you make a change to the section dimensions.

- Close the sections spreadsheet and save the project. LARSA 4D projects are normally saved in the “My Documents\LARSA Projects” folder.

Project files are plain text files which can be viewed and compared outside of LARSA 4D. However, it is rarely necessary to do so.

Joints and Members (Drawing)

The next step is to add joints and members for the frame. LARSA users tend to use the z-axis as the elevation axis, so that’s the convention we’ll use here. When LARSA starts, the graphics window opens with the x-axis going to the right and the z-axis going up: a side view. The y-axis is going into the screen, following the right-hand rule. Coordinate axis arrows are always shown at the bottom-left of the graphics window as a reference.

- Turn on the grid by clicking the **Grid** button at the bottom left of the graphics window. A grid with default extents in the x-z plane appears.
Then click the “E” (Extents) button beneath the Grid button to setup the grid extents as shown in the figure. Click the extents button once again to close the panel.

Click the Zoom Extents tool on the tool bar to properly position the grid on the screen:

Activate the drawing command Draw → Geometry → Members.

On the Draw Members tool window, set Polyline as the drawing method. Also change the increment from 0.0 to 1 foot.

Click the grid point (-15, 0) (and then release the mouse button), and then click the grid point (-15, 15). LARSA 4D adds joints at the two points, and then creates a member between them.
If you click the wrong point for the start of a new member, click your mouse’s right button to cancel the new member. If you draw a member to the wrong position, undo the member using Edit → Undo, or CTRL+Z.

- Click (15, 15) to add the second member.
- Lastly, click (15, 0) to add the third member.
- To finish drawing, click the close X (the ‘x’) on the floating Draw Members window. Turn off the grid by clicking the Grid button again.
- Zoom in on the frame by clicking the zoom extents tool in the toolbar again.
An alternative method for adding joints and members for the frame is by using input spreadsheets. For the joints, select from the menu **Input Data → Geometry** to display input spreadsheets for geometry objects. Select the joints spreadsheet and enter the data. To enter the member data, select the members spreadsheet by clicking the **Members** tab and enter the data.

**Restraints and Properties (the Model Data Explorer)**

LARSA 4D must be told where the model is fixed to its environment, i.e. where its supports are. We’ll support the frame at the two lower joints by making them fully fixed, that is, fixed in all six directions of displacement. Note that while the upper two joints are left free, which means they are allowed to move, the connections between the members coming into the joints are still perfectly stiff.

Although this is a two-dimensional model, LARSA 4D is a 3D analysis program. That means that you must be careful to create restraints in all six directions: three directions of translation and three directions of rotation. Every model must have restraints to prevent free motion (also known as rigid body motion) in any of the six directions, regardless of which directions have loading. In this model, we must ensure that the model is restrained in the Global Y direction even though we will not create any loads in that direction. We have chosen in this model to restrain the base joints in all six directions.

Alternatively, you may use Universal Restraints (in the Input Data menu). Universal Restraints apply restraints in one or more directions to all joints throughout the project. In a 2D model such as this, Universal Restraints are typically
applied in y-translation and x- and z-rotation. When the correct Universal Restraints are applied, there is no need to restrain those directions again at supports.

**About Selection**

Every structural object is either selected or unselected. LARSA 4D provides various tools to modify the selection state of objects, including the Selection/Unselection graphics tools, Select Special, Select by Plane, and Select/Unselect All. Selected objects are generally displayed solid, while unselected objects are generally displayed dashed.

The selection state of objects is important because most modeling operations, such as modifying the properties of objects, applying transformations, and meshing, operate only on the selected objects. Therefore, the objects to which you want to apply an operation must be selected — and everything else unselected — before applying the operation.

**The Model Data Explorer**

The Model Data Explorer on the right-hand side of the screen is used to view and modify the attributes of selected project geometry. The Model Data Explorer is currently showing the attributes of selected members because we were last drawing members. We’ll come back to the members later.

zos Where the Model Data Explorer says Members, click it and change it to Joints.
Geometry starts off selected, which is why the explorer says “4 Joints selected.” The explorer also shows only the attributes that the selected geometry has in common. Since the x- and z-coordinates of the joints are all different, those fields are left empty in the explorer. But all of the joints have a y-coordinate of 0.00, and that is shown in the explorer.

In order to set the “restraints” on the lower two joints to fixed, we will need to unselect the other joints.

**About Graphics Cursor Tools**

There are six graphics cursor “tools” that define the behavior of the mouse in the graphics windows. The tools are displayed together on the graphics toolbar, shown below. Exactly one tool is active at all times, and the active tool is shown highlighted. In the picture below, the Pointer Tool is active.
The Pointer tool is the primary tool of the graphics windows. It is used to examine objects (by clicking them) and to quickly manipulate objects (by right-clicking them).

The Select and Unselect tools to its right select and unselect objects. When one of these tools is the active mouse cursor tool, you may:

- Click-and-drag a window around structural objects to select or unselect the objects. Dragging from right to left will include all objects that are at least partially within the window. Dragging from left to right will include only the objects that are entirely within the window.
- One-Click: Click single objects to select or unselect just one object at a time. If more than one object is under the mouse cursor, you will be prompted to choose which one to select.

### Setting Joint Restraints

- Activate the unselect tool by clicking on it in the toolbar.

- Then unselect the top joints by dragging a window around the two joints on the top. (Click and hold the mouse button down while dragging.)

The joints and the member within the window will be shown as unselected: the joints are drawn hollow, and the member is drawn dashed. Since we’re only editing the attributes of the joints, the selected state of members doesn’t matter.

Back in the Model Data Explorer, you’ll see it now says “2 Joints selected” and the z-coordinate field reads 0.00, indicating both selected joints have that value.


- Then click the checkmark at the top to confirm the change. If you do not click the checkmark, no change is made.

The graphics window will show full support icons below the two joints.
Setting Member Attributes

The material and section properties that were imported at the start must be applied to the members in the model. We will set the properties of the columns first — remember that the horizontal member was already unselected earlier.

Switch to the members panel of the Model Data Explorer. (Where it says Joints, change it back to Members.) Check that it reads “2 Members selected.”

Change the section attribute to “W8x31 [DB:American]” and the material to “A992”.

Note that the changes are shown in bold as a reminder that you need to click the checkmark to confirm them. Click the checkmark.

We have to setup the top beam to be W12x40. We can do that on the spreadsheet to show another way of entering data in LARSA 4D.

From the menu go to Input Data → Geometry and then change to the Members tab.

Set the section (section at start) of member 2 to “W24x76 [DB:American]” and its material to “A992”.
The orientation angle (sometimes just “angle”) attribute of members determines how the section definition is oriented. For the columns, the orientation angle determines whether the flanges will point horizontally (global x) or into/out-of the screen (global y). The orientation angle must be set on every member element. For the horizontal member (the beam), the orientation angle must be used to orient the flanges horizontally and not have the beam sitting on its side.

Section definitions have their own local axis called the reference axis. The reference x/y axes typically line up with the principal axes of the section. In the AISC database of I shapes that comes with LARSA 4D, the reference z-axis is parallel to the flanges. This is typically called the strong axis, referring to the strength in bending about this axis.

In order to make the horizontal member, the beam, oriented properly the reference z-axis of the member must be made parallel to the global y-axis. Take a moment to study the diagram below to understand this crucial point.
For horizontal beams like this one, the orientation angle is defined as the angle measure between the global z-axis and the section reference z-axis, i.e. between what is typically the elevation axis and the strong axis. In our example beam, the axes are perpendicular, making the orientation angle 90°.

Imagine rotating the beam in from 0° to 90°. Use the diagram below to help you understand the relationship between the orientation angle and the global and section reference axes.
The orientation angle for columns, that is, member elements parallel to the global z-axis, is given differently: The angle is measured between the section reference z-axis, as before, and the global negative x-axis. An angle of zero means the strong axis is parallel to the global x-axis. An angle of 90° means the strong axis is parallel to the global y-axis.

In this tutorial, the frame will be subjected to horizontal wind loading. Therefore the flanges, the strong axis, and the section reference z-axis point in the direction of the global y-axis. An orientation angle of 90° will be used for these member elements as well.

Study the figure below, which depicts a column when viewed from above, to understand the role of the orientation angle in this model.
We will now set the orientation angle of all three elements to 90 degrees.

- Scroll to the right in the spreadsheet and set the orientation angle in all three rows to “90”. The orientation angle is always entered in degrees.
- Close the geometry spreadsheets.
- Select all members before going on. Use Selection → Select Objects → Select All.

**About Numbering**

Every geometry object in a project has an ID number which can be set and changed by the user. When it’s not set by the user, LARSA 4D assigns a number starting from 1 each time a new object is created. These numbers are used when applying loads in the spreadsheets.

The joints in our project are numbered 1 through 4, starting with the first joint we created.

Each type of object is numbered independently, and so the members are numbered 1 through 3.

LARSA 4D doesn’t expect the user to remember all of the numbers, so numeric labels in the graphics window can be turned on to see what each object’s number is.

We will use a graphics window keyboard shortcut to turn on numbers.

- Click some empty space in the graphics window to make sure the Windows focus is in the graphics window. Graphics window shortcut keys only work if the graphics window has the focus.
- Then press N on your keyboard. N is the shortcut key for numbering.
The joints are now shown with their numbers, in blue — the same color as the joints as a reminder that the labels are for the joints.

Press N again and the members, rather than the joints, will be numbered — this time in the color of members. Pressing N cycles through the different numberings available.

Note the numbering.

Press N again to turn off numbering.

You can also turn on numbering, and other types of labels, using Graphics → Show → Labels.

Load Cases

This model will have two load cases. The first load case will simulate self-weight. The second load case will simulate wind. Load cases are created in the Load Cases Explorer.

To switch from the Model Data Explorer to the Load Cases Explorer, click the Load button at the top of the explorer panel.

Click the Add Load Case button twice to create two new load cases.

Rename the first load case to “Dead”:

Click the load case.

Press F2 on your keyboard, or right-click the load case and choose Rename.
Enter the new name, and then press Enter to complete the change.

Do the same for the second load case, naming it “Wind Load.”

**Automatic Self-Weight Computation**

LARSA 4D can automatically compute and apply the self-weight of a structure due to gravity. It is applied as a uniform load with a magnitude determined by the unit weight of the material assigned to a member and the cross-sectional area of the section assigned to a member.

Right-click the first load case and choose Properties. The Weight Factor fields set the direction and magnitude of gravity. Since gravity pulls in the direction of the negative z-axis in this model, enter -1 in the Z field. Or, simply click the –Z button. Click OK.

Note that the Load Cases Explorer shows that self-weight is applied in this case.

**Adding Loads using Spreadsheets**

Enter the loads spreadsheet for the second load case by double-clicking the load case. You may also click once and then click the spreadsheet icon in the explorer.

Switch to the Member Loads tab.

Each row in the spreadsheet represents a load, except for the last blank row which is present in every spreadsheet. The last blank row lets you start typing immediately to add a new row at the end.

You’re in the Member column which is for the ID of the member that the load will be applied to. We want to apply uniform loads to members 1 and 3 in the global-x direction.

Type the number 1 for the ID. A new row representing a load on member 1 is added to the spreadsheet.

Click the type Point Force and change it to Uniform Force.

The Direction column reads Global Z. This indicates the load will be acting in the up direction. We want a horizontal load in the global-x direction, so we will need to change the direction and enter a positive magnitude load.

Change the Direction to Global X.

In the Magnitude at Start column, enter 15 and then press Enter. The load force units have been set to kips at the start of this tutorial.

The Magnitude at End column is blank and cannot be edited for this type of load. This type of load has a uniform magnitude throughout.

The Start Position and End Position columns give the start and end position of the load on the member, 0 being the start of the member and 1 being the end. Leave these as they are so that the load spans the whole member element.

The graphics window, which remained underneath the spreadsheet, now shows the load on the member. You can switch back to the graphics window temporarily to see if the load definition is correct.

Click the Graphics View 1 window button at the bottom of the LARSA 4D window. Verify the new load looks correct. Then switch back to the spreadsheet by clicking the Wind Load: Member Loads window button.

Place the spreadsheet cursor back in the first cell of the last, blank row, and type 3 to add a new load on member 3. Set its attributes the same as the previous load.
Close the spreadsheet window.

Note that only the wind load is shown in the graphics window. The graphics window shows the loads of the active load case only. The active case is the last load case clicked in the Load Cases Explorer and is indicated at the top left of the graphics window.

Running the Analysis

We're ready to run an analysis now.

- Click **Analysis → Linear Static / P-Delta Analysis**.
- There are no options for the linear analysis. Click **Analyze**.

You will be prompted to save your project before continuing. Do so.

The LARSA 4D Analysis Engine will appear. The analysis of a model of this size is very fast. Once the engine prints out “You may now close this window,” you can close the engine, returning to LARSA 4D.

Back in LARSA 4D, the Load Cases Explorer has automatically been replaced by the Analysis Results Explorer so that it is ready for you to explore the results.

Results

- Set the results units to feet and kips in **Results → Units**.

In a simple analysis like this, there is a one-to-one correspondence between input load cases and output result cases. That is, each load case in the Load Cases Explorer is analyzed to a result case in the Analysis Results Explorer. But this is not always the case in more advanced analysis types. For instance, a single moving load case generates a result case for each position of a vehicle on a path. In Staged Construction Analysis, results are arranged according to construction stages and steps, and not load cases. Remember that load cases are for input and result cases are for output.

- Click the small plus sign next to where it reads Load Cases in the explorer. This expands the group to show the two result cases corresponding to the two load cases we created earlier.
Click the plus sign next to Load Cases to expand that group

**Reaction Forces (Numerical)**

- Click the “Dead” result case to select it.
- To view reactions numerically in results spreadsheets, click **Results → Spreadsheets → Joint → Reactions**.

The spreadsheet shows the reactions at the two supports for the active result case, which is the “Dead” load case. Recall that joint 1 is the left support, and joint 4 is the right support.

- Click Wind Load in the Analysis Results explorer to switch to the second result case. The spreadsheet updates immediately.
- Now, hold CTRL and click Dead again. By holding CTRL, you instruct LARSA to activate an additional case without deactivating the first one.

When two or more result cases are active, results spreadsheets show the results from each case. The Result Case column indicates which case the row of results applies to.
Envelopes

At the top of the spreadsheet, change Min/Max For from None to Force — Z.

This turns on an envelope for the spreadsheet. Rather than showing the results for each selected case, only the minimum and maximum are shown for each reaction.

The first row for each joint shows the result case that had the minimum value for Force — Z. All of the values in that row come from the same result case, so the row shows the minimum z force and the corresponding forces in other directions for the same case. The second row shows the result case that had the maximum value for Force — Z.

Joint Reaction Envelope

The minimum (or most negative) Z reaction on the left joint is due to the wind load. The negative Z reaction there on joint 1 indicates an uplifting force.

Shading in the Force Z column is a reminder that envelopes have been turned on.

Close the spreadsheet.

Member Stresses

To see member stresses, use Results → Spreadsheets → Member → Stresses.

Both result cases are still active. Let’s have just Dead result case be active. Click the Dead result case to select it and unselect other result cases.

The stresses spreadsheet shows the stress at stations along each member. The number of stations can be set by the user. Let’s use five segments (six stations).

Go to Results → Results Display Settings.

In the top-right box set Segments to 5. (These options are also used for graphical results diagrams.)
Set member results segments to 5

Click **OK**.

In the spreadsheet, for each member there are stations 0 through 5. 0 is the start of the member. 5, since we set 5 segments, is the end of the member.

The normal stresses are given at what are called **“stress recovery points”** for the member’s cross-section definition. The stress recovery points for an I-shape are at the four extreme corners. You can use the sections spreadsheet to determine the local y and z coordinates of each of the stress recovery points on the cross-section. Normal stress is the sum of extensional stresses caused by the axial force and bending moments at the station.

The last column, Max ABS Total Stress, reports the normal stress with the largest magnitude in that row.

Close the spreadsheet.

**Member Force Diagrams (Graphical Results)**

Member forces and stresses can be viewed graphically as well. Find the graphical results toolbar:

Click the Member Forces icon, which is the third icon from the left.
The Graphical Results Options floating tool window will appear somewhere on your screen, shown below. Find it and change **Axial Fx** to **Moment Mz**.

Member forces are reported in local directions, rather than global directions. Recall that the strong axis for standard I shapes is the z-axis. This is why we select Mz moments.

The graphics window now shows member force diagrams for all of the members. It’s actually three diagrams at once, one for each visible member element.

Look at the diagram for the horizontal member. It’s not very smooth. This is because we choose five segments earlier. Forces are being reported at the same number of segments graphically, and straight lines are drawn between the stations.

You can increase the number of segments to, say, 20 using **Results → Results Display Settings**. Keep in mind that in larger models and especially with influence analysis results, the more stations the longer it will take to compute or display results.

Instead, it would be more appropriate to revise the model to ensure there is a joint at all locations where we are interested in forces. Results are always accurate at joints.

Turn off graphical results by clicking the first button in the graphical results toolbar.

Split every member in two using **Modify → Break Members**. Leave the number of segments at 2. Click **OK**.

Re-run the analysis (**Analysis → Linear Static**).
Turn on the member force diagrams for the Dead result case again.

Note that the curve is twice as smooth and also now properly indicates the maximum.

Switch between the two result cases by clicking them in the Result Cases Explorer.

Deformed Model

Displacements can also be viewed graphically.

Click the Deformed Model icon, which is the second icon in the graphical results toolbar.

The scale factor of results can be adjusted using a slider at the bottom of the Analysis Results Explorer. For the Wind Load case at a scale of 1, the deformation is already visible.

Note that the members are still drawn as straight lines. Although the analysis accounts for the bending properties of member elements, the deflections along members between joints are not computed during the analysis. Break members into smaller pieces if deflections along the span are needed. Note that adding more joints in a model such as this will not affect the results. Adding more joints only has the effect of reporting deflections and other results at more locations.

Turn off graphical results using the None icon, which is the first icon in the graphical results toolbar. You may also use the Results → Graphical menu.

This concludes this tutorial.
Creating a 3D Frame

This tutorial will extend the 2D frame created in the previous tutorial into a three-dimensional structure. The key concepts we will go over are:

- Copy/Paste in the Input Spreadsheets
- Range Editing
- Graphically Rotating the View
- Stress Diagrams

Begin by opening the 2D frame project you created in the previous tutorial, if it is not already open, and then save the project under a new name.

Duplicating Joints

We will use copy/paste in the input spreadsheets to duplicate the joints in the model, putting the new joints 7 feet behind where they are now.

Open the joints spreadsheet using \textit{Input Data} \rightarrow \textit{Geometry}.

In the 3D frame, we want a new set of joints, with the same x- and z-coordinates, and restraints, as the joints we have now. The restraints are represented in the two DOF columns in the spreadsheet, Translation DOF and Rotation DOF.

Select the coordinates and DOF of the joints. Drag through the seven rows and five columns. Be sure to NOT include the ID column because the new joints must have different IDs.

<table>
<thead>
<tr>
<th>Joints</th>
<th>Members</th>
<th>Plates</th>
<th>Springs</th>
<th>Mass Elements</th>
<th>Isolators/Beatings</th>
<th>Tendons</th>
<th>Lanes/Surfaces</th>
<th>Brackets</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joints</td>
<td>Slave/Masters</td>
<td>Rigid Links</td>
<td>Rigid Diaphragms</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ID</td>
<td>X (ft)</td>
<td>Y (ft)</td>
<td>Z (ft)</td>
<td>Translation DOF</td>
<td>Rotation DOF</td>
<td>Displacement UCS</td>
<td>Assignment</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>15</td>
<td>0</td>
<td>0</td>
<td>all fixed</td>
<td>all fixed</td>
<td>Global</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>15</td>
<td>0</td>
<td>15</td>
<td>all free</td>
<td>all free</td>
<td>Global</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>15</td>
<td>0</td>
<td>0</td>
<td>all free</td>
<td>all free</td>
<td>Global</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>15</td>
<td>0</td>
<td>0</td>
<td>all fixed</td>
<td>all fixed</td>
<td>Global</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>15</td>
<td>0</td>
<td>15</td>
<td>all free</td>
<td>all free</td>
<td>Global</td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>15</td>
<td>0</td>
<td>0</td>
<td>all free</td>
<td>all free</td>
<td>Global</td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>

Copying Joint Coordinates

- Then copy the selection to the clipboard. You can use \textbf{Edit} \rightarrow \textbf{Copy} or the usual Windows shortcut \textbf{CTRL+C}.
- Position the cursor in the last row of the spreadsheet, the blank row, and in the X column.
- Paste the clipboard back, using either \textbf{Edit} \rightarrow \textbf{Paste} or \textbf{CTRL+V}.
Pasting Joint Coordinates

Duplicates of the original joints are added, numbered 8 through 14.

We need to change the y-coordinates of the new joints all to 7, but rather than changing each one-by-one, LARSA 4D has a range-update tool.

- Select the y-coordinate cells to change. Then enter 7 in the range edit field in the toolbar, shown here:

  ![Range Edit Tool](image.png)

- Click the checkmark beside the range edit field to apply the change.

- Keep the spreadsheet open but go back to the graphics window by clicking the Graphics View 1 button in the window bar at the bottom left of the LARSA 4D screen.

- Nothing has change because the new joints are directly behind the old ones. Change to perspective view using Graphics → Perspective Projection, or by typing the graphics shortcut key P. Zoom extents (using the graphics toolbar) if you cannot see the whole model.

We did this the hard way to demonstrate the use of the spreadsheets. There is also a Translate tool in the Modify menu which will copy and translate joints in one step.

Adding New Member

Next, we need to add new members.

- Return to the Geometry spreadsheet using the window bar again by clicking the Joints button. Click the Members tab.

In this spreadsheet, each row represents a member in the project. Members go from a start joint to an end joint. The I-Joint column is the ID of the start joint for the member, and the J-Joint column is the ID of the end joint.

Rather than copy/pasting, add three new rows into the spreadsheet using the Add Rows icon in the toolbar.
Click the Add Row icon eight times, adding members 7 through 14. The Add Row button is the first icon shown in the figure above for the Range Edit Tool.

Set the I- and J-Joint fields for the new members as shown in the figure below:

<table>
<thead>
<tr>
<th>ID</th>
<th>I-Joint</th>
<th>J-Joint</th>
<th>Span</th>
<th>Type</th>
<th>Section at Start</th>
<th>Section at End</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>7</td>
<td>8</td>
<td>12</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>12</td>
<td>9</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>9</td>
<td>13</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>13</td>
<td>10</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
<tr>
<td>11</td>
<td>11</td>
<td>10</td>
<td>14</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
<tr>
<td>12</td>
<td>12</td>
<td>14</td>
<td>11</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
<tr>
<td>13</td>
<td>13</td>
<td>9</td>
<td>2</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
<tr>
<td>14</td>
<td>14</td>
<td>10</td>
<td>3</td>
<td>Beam</td>
<td>(same as start)</td>
<td>(same as start)</td>
<td>A992</td>
</tr>
</tbody>
</table>

New Member Connectivity

Usually you will take some time to set your joint IDs systematically so that member connectivity is easier to input and understand.

Change the section, material, and orientation angle to be the same as the other members: Use W8x31 for the columns and W24x76 for the beams (including the new cross-bracing between the old and new parts of the frame). Switch the graphics window and turn on member numbering to figure out which member is which.

Close the spreadsheet.

Viewing the Structure from Different Angles

It is often useful to view 3D structures from different angles to get a better view of it.

To rotate the structure on the screen, first activate the rotation tool, shown in the figure below:

The Rotation Tool

Recall that only one tool is active at a time, and this tool controls what the mouse does in the graphics window. With the rotation tool, you use the mouse to rotate the structure.

Drag the structure side to side or top to bottom to see it from different angles.

To put the structure in a perfect top, front, or side view, use the projection tools on the toolbar: they are the first four tools on the same row. (They’re green.)

Return the view to a front view (the second projection icon).
Running the Analysis

The input data is finished.

Run a linear static analysis.

Results

To verify the results, we will look at stress diagrams. Let’s check the envelope of the stresses on the model.

Set the results units to feet and kips in Results → Units.

Turn on graphical stress diagrams. It’s the one to the right of the member force diagram icon:

Click the Dead result case to activate it. Rotate the structure to get a better view.

If the rotation tool is not active, activate it. Then drag the structure so you can see it from above.

Stress Diagrams

Besides the stress diagram, the uniform loads that represent the self-weight may also be shown. To turn this off use Graphics → Show or the graphics keyboard shortcut O (O is a mnemonic for 'options'). Then uncheck the Analyzed
Loads option. The Input Loads option refers to view loads explicitly entered in a load case during model input. This would not include the generated loads for automatic self weight. Analyzed Loads on the other hand is for displaying all member and plate loads included in a result case, either from explicit user input or from automatic generation.

There are too many diagrams at once. Fortunately, LARSA 4D shows diagrams only for selected objects. That means that we can unselect what we don’t want to see.

- Use keyboard shortcut U or Select → Unselect Objects → Unselect All to unselect everything.
- Activate the mouse cursor selection tool
- Click one of the horizontal members to select it.

Only its stress diagram will show. You can adjust the display size of the diagram using the slider beneath the Analysis Results Explorer.

The stress diagram is for Stress Recovery Point 1 (abbreviated “Stress Point 1”), which is the corner in the +z/+y quadrant of the section definition. You can view the stresses at different stress points using the floating options window.

That is the end of this tutorial.
Tunnel Example and Generation Tools

This tutorial will create a tunnel-type structure to demonstrate the extrusion tool. We will not run an analysis on the model. In this example you will see:

- Extrusion
- Rendering
- User Coordinate Systems

Model Setup

- Start a new project, and enter joints at (0,0,0), (0,0,25), (25,0,25), and (25,0,0).
- Connect the joints with members. You will need members from joint 1 to 2, 2 to 3, and 3 to 4.
- Close the spreadsheet.

Extruding the Tunnel

We will use the extrusion tool to extrude this frame in the y direction, creating a tunnel.

- Open Draw → Generation.
- Click Extrusion.
- Set # Repetitions to 20 and Delta Y to 5.

This means that the structure will be extruded in 5 foot increments 20 times. Joints will be extruded into members, and members will be extruded into plates (surfaces).
Extrusion Tool

- Click **OK**.
- Zoom extents and use the rotation tool to view the structure.

This created a tunnel with beams at 5 foot intervals, for 20 intervals — or, 100 feet.

- Turn on graphical rendering using **Graphics → Complete Rendering** to get a better view. Then turn it off (**Graphics → Simple Rendering**) when done.
In the last section we extruded the initial structure along one axis in the global coordinate system. The global coordinate system is a rectangular/cartesian coordinate system, meaning it has x, y, and z axes which are perpendicular. You may also extrude along an axis of any user coordinate system, which can be rectangular, cylindrical, spherical, or a bridge path.

Extrusion using a cylindrical coordinate system is usually used to construct a circular or cylindrical structure, such as a vessel. We will demonstrate that next.

Start a new project to clear out the geometry.

Open the CoorSystems panel of the Model Data Explorer. (For instance, if the Model Data Explorer reads “Joints” change it to read “CoorSystems”.)

This is the place to create user coordinate systems.
Click the plus sign in the model data explorer to create a new coordinate system.

A window will appear asking for information about the new coordinate system. We will need to choose the type of the coordinate system, the location of its origin in global coordinates, and its orientation relative to the global coordinate system.

Change the UCS type from Rectangular to Cylindrical.

For a vessel, we will choose the cylindrical type. A cylindrical coordinate system has three axes: \( r \), \( \theta \), and \( z \). When a cylindrical coordinate system is in use, joint coordinates and extrusion commands are given using these axes, rather than the rectangular \( x \), \( y \), and \( z \) axes. When we create a new cylindrical user coordinate system, the new user coordinate system’s origin is placed at the global origin. Its \( z \)-axis matches the global \( z \)-axis. And the angles \( \theta \) are measured counter-clockwise from the global \( x \)-axis.

To demonstrate, we will put the user coordinate system on its side so that we can create a vessel on its side. You can imagine the vessel being supported at several points so it does not roll away.

To put the user coordinate system on its side, we must change the coordinate system’s direction vectors. The coordinate system \( z \)-axis direction vector represents the direction of the actual coordinate system \( z \)-axis. In addition, the coordinate system \( x \)-axis direction vector represents the axis from which the angles \( \theta \) are measured from.

Change the X Axis direction vector to \((0, 0, 1)\).

Notice that the other direction vectors update so that they remain perpendicular.

Change the Z Axis direction vector to \((1, 0, 0)\).
Cylindrical User Coordinate System

Click OK.

You can find the new UCS in the Model Data Explorer.

A model may have any number of user coordinate systems. When a UCS is made active or “current”, then all coordinates are edited and displayed in that system.

Right-click the UCS and choose Make This the Current UCS.

To create the vessel, we will use two steps of extrusion. First we will create a single point on the circumference of the vessel and extrude it around the theta-axis, to create a circle of joints connected by members. Then we will use a second step of extrusion along the z-axis to create a cylinder out of the circle.

Create a joint at (r=10, theta=0, z=0). You can use the joints spreadsheet.

Use the Extrusion command (Draw → Generation and then click Extrusion) to extrude this joint 36 times at 10 degrees each in the theta direction. By leaving the delta r and z fields at zero, the joint will remain the same
distance from the origin and in the same plane. Be sure **Merge Duplicate Joints** is checked so that the 36th joint will be the first joint again without creating a new one at the same location.

We need to have 36 repetitions and not 35 so that the last step extrudes a member and connects it back to the first joint, completing the circle.

**Extruding a Circle**

Use Extrusion again to extrude this circle 36 times with delta z of 2 feet.
Extruding a Cylinder

At this point we have both plates and members in the model. The first step of extrusion created a circle. This was crucial so that in the second step plate elements could be extruded from them. However, during the extrusion process we also extruded members from the joints running lengthwise along the vessel, and the extrusion process also copies the circle repeatedly along the vessel’s length. We need to now delete those elements. The member elements are visible if you turn on Graphics → Shrink.

- Unselect All.
- Use Selection → Select Objects → All Members to select all of the member elements in the model.
- Use Modify → Erase to erase all of the selected geometry, i.e. the members.

The last step is to seal off the top and bottom. While it is possible to use the Mesh command within the bottom and top circles of joints, this generates a rather uneven mesh of triangular plate elements. It is always recommended to use quadrilateral plate elements that are as close to squares as is feasible, when it is possible to do so.

We can create the bottom surface by drawing rectangular plates.

- Put the vessel into a side view so that you can no longer see the top and bottom open ends.
- Select using the mouse window selection tool the joints at the left edge of the vessel.
- Turn on Graphics → Hide Unselected.

The unselected joints and plates (everything else but our initial circle of joints) will be hidden from the display.

- Now put the model into a front view so that the circle of joints is clearly visible and the coordinate axes are straight.

Before we use the draw command, we will restore the global coordinate system as the active coordinate system. We do this because configuring the draw command for drawing in a cylindrical coordinate system is more complicated.

- In the CoorSystems panel of the Model Data Explorer, right-click the UCS and choose Make Global System the Current UCS.
Start the [Draw] → [Geometry] → [Plates] command. Set the Break (X, Y) values to 8 and 10 so that when we draw a single rectangle it is automatically subdivided into pieces that will line up roughly with the joints we have in the circle. Draw a large rectangular plate inscribed in the circle as shown in the figure below. Start with the upper-left point and click the three other corners in clockwise order.

We'll free-hand the rest.

Move clockwise through the empty space and draw approximately square quadrilateral plates, and triangular plates where needed, to fill in all of the space. To draw a triangular plate, click the three joints and then click the first joint again to finish drawing the plate.
When you have filled in all of the space, close the floating Draw window to finish the drawing command.

Use the Modify → Translate command, with Make A Copy checked to duplicate the bottom cap into the top cap position.
The Vessel
Basic Live Load Analysis

In this model, we’ll create a simple bridge and run a moving load analysis over it. The moving load analysis is the simplest live load analysis available in LARSA 4D. The model will be a three-span bridge, with spans of length 30, 40, and 30. The intermediate supports will be pins. In this section, you will see:

- Break Members
- Connecting Vehicle Databases
- Creating a Lane
- Moving Load Cases
- Stepping through Generated Result Cases
- Graphical Stress Envelopes

Model Setup

- Import a concrete material and section of your choosing.
- Set the coordinate units to feet in Input Data → Units.
- Using the joints spreadsheet, add four joints: at x = 0, 30, 70, and 100.
- Set the joints at 0 and 100 to be fully fixed, in both translation and rotation.
- Set the joints at 30 and 70 to be fixed fully in translation, but free in rotation.

<table>
<thead>
<tr>
<th>ID</th>
<th>X (ft)</th>
<th>Y (ft)</th>
<th>Z (ft)</th>
<th>Translation DOF</th>
<th>Rotation DOF</th>
<th>Displacement UCS</th>
<th>Assignment</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>all fixed</td>
<td>all fixed</td>
<td>Global</td>
<td>No</td>
</tr>
<tr>
<td>2</td>
<td>30.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>all fixed</td>
<td>all free</td>
<td>Global</td>
<td>No</td>
</tr>
<tr>
<td>3</td>
<td>70.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>all fixed</td>
<td>all free</td>
<td>Global</td>
<td>No</td>
</tr>
<tr>
<td>4</td>
<td>100.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>all fixed</td>
<td>all fixed</td>
<td>Global</td>
<td>No</td>
</tr>
</tbody>
</table>

Add or draw members between the joints, and set their section, material, and orientation angle (90°) attributes.

<table>
<thead>
<tr>
<th>ID</th>
<th>I-Joint</th>
<th>J-Joint</th>
<th>Span</th>
<th>Type</th>
<th>Section at Start</th>
<th>Section at End</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>2</td>
<td>-</td>
<td>Beam</td>
<td>Rectangle</td>
<td>(same as start)</td>
<td>Fc_4</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>3</td>
<td>-</td>
<td>Beam</td>
<td>Rectangle</td>
<td>(same as start)</td>
<td>Fc_4</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>4</td>
<td>-</td>
<td>Beam</td>
<td>Rectangle</td>
<td>(same as start)</td>
<td>Fc_4</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Members Input
When the deflections within a member are important, as they are here, it is normally recommended to break the member into smaller pieces.

1. Go to the graphics window and start **Modify → Break Members**.
2. Enter 6 for the number of segments and click **OK**.

Each member will be divided into six pieces.

![Image of members broken into pieces]

### Vehicle Load Pattern

Before running a live load analysis, we need to provide LARSA 4D with load patterns that define the type of vehicle to pass over the model. LARSA 4D comes with a database of standard vehicle types which you must connect to your project.

1. Go to **Input Data → Connect Databases**.
2. Click **Connect Standard Database**.
3. Choose “movedata.dml”.
Connect the standard load patterns database

This load pattern database is one of LARSA 4D’s standard load pattern databases that contains many frequently used vehicles.

- Click OK.

**Lane Definition**

We must also provide the path for the vehicle to follow. Creating paths for simple models is easy, since there is only one path the vehicle could take.

- Activate **Draw → From Selected Members → Lane**.

A lane down the length of the bridge is created. The lane should hover above the members, which you can see if you chose a large section, and if lanes are included for display in **Graphics → Show**. This is because it is sitting on top of the members, and LARSA 4D knows the top of the member is half the depth above the centerline.

You could also see the lane in the Lanes panel of the Model Data Explorer.

- Open the Model Data Explorer and change to the Lanes panel.
- Right-click “Lane 1”, the new lane, and choose **Edit Path & View**.

A spreadsheet and a new graphics window will open. The spreadsheet is the path definition that controls how the vehicle loading will march through the model. The path consists of geometry control points, which are points in 3D space that the lane passes through. These points are entered relative to the members of the model.
Lane Path

Note how the last entry has the last member repeated twice. The first time represents a control point at the start of the last member. The second time represents a control point at the end of the last member, bringing the lane to the end of the bridge.

We will not actually modify the path here.

- Take a moment to look over the path definition. Then close the path spreadsheet. The graphics window will automatically close along with it.

Moving Load Case

The next step is to create a load case which specifies to march a load pattern along the lane.

- In the Load Cases Explorer, add a new load case named “Live Load”.
- Enter the loads spreadsheet for the case (double click the load case).
- Change to the Moving Loads tab.

Each row in this spreadsheet represents the marching of a load pattern on a lane. You can load more than one lane at a time, if your project has multiple lanes, for the effect of simultaneous marching loads. (To have non-simultaneous loads, just use two load cases.)

- Add a row to this spreadsheet.
Change Lane Loaded to “New Lane 1”, which is the lane you just created.

Set Load Pattern to HS20-44, which comes from the movedata.dml database.

The remaining options set the increment between load steps, the direction of travel, and other options.

<table>
<thead>
<tr>
<th>Lane Loaded</th>
<th>Load Pattern</th>
<th>Applied Load Direction</th>
<th>Load Factor</th>
<th>Direction of Travel</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Lane 1</td>
<td>HS20-44</td>
<td>Global -Z</td>
<td>1.0000</td>
<td>Forward</td>
</tr>
</tbody>
</table>

Moving Load Options

Close the loads spreadsheet.

Moving Load Analysis

To run the analysis, use Analysis → Moving Load Analysis.

There are no options for this analysis, so click Analyze and save the project when prompted.

When the analysis completes, close the analysis window.

Stepping Through Displacements

Set the results units to feet and kips in Results → Units.

The Analysis Results Explorer contains generated result cases for each position of the vehicle on the bridge, at 1 foot intervals.

In the Analysis Results Explorer, click the plus sign next to Moving Load Cases.

Then click the plus sign next to Live Load.

This expands the load group, which contains the generated result cases.

Click the first case “Dist: 0.00” to activate it.

Make sure Analyzed Loads are on in Graphics → Show.

Make sure Member Span Deflections are on in Results → Results Display Settings.

Turn on the deformed model graphical view.

There is no deformation in this step because the vehicle’s first axle is right on top of the first support.

Click Dist: 20.00.

Adjust the scale factor below the Analysis Results Explorer until you see some deformation.
Click the result case again, and use the down arrow on the keyboard to step through the results.

Deformed Model

Stress Envelopes

Turn on stress diagrams.

If stress diagrams are being drawn into the screen, you may need to use the rotation tool to see the diagram.

It is important in a live load analysis to view the envelope of results over all of the positions of the vehicle.

Click the first result case, Dist: 0.00.

Scroll to the bottom of the result cases.

Hold SHIFT while clicking the last case, Dist: 129.00. (This is the length of the bridge plus the length of the vehicle so that the last axle moves all the way to the end.)

All of the result cases from Dist: 0.00 to Dist: 129.00 are selected. They are shown in blue to indicate they are selected. The graphical diagram updates immediately to show the envelope of values at each position.
Index

2D frame tutorial, 9
3D frame tutorial, 31
break members, 47
copy and paste, 31
drawing, 9
example
  Basic Live Load Analysis, 47
  Creating a 2D Frame, 9
  Creating a 3D Frame, 31
examples, 31
explorers, 9
extrusion, 37
graphical results diagrams, 9
graphical stress envelopes, 47
input spreadsheets, 9
joints, 9
lanes, 47
live load tutorial, 47
load cases, 9
materials, 9
members, 9
moving load analysis tutorial, 47
moving load cases, 47
range editing, 31
rendering, 37
result cases, 47
results diagrams, 9
results spreadsheets, 9
sections, 9
selection, 9
stress diagrams, 31
training manual,
tunnel structure tutorial, 37
tutorial
  Basic Live Load Analysis, 47
  Creating a 2D Frame, 9
  Creating a 3D Frame, 31
  Tunnel Example and Generation Tools, 37
units, 9
user coordinate systems, 37
vehicle database, 47
view, 31